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1 Introduction

AZ Interface (AZl) is tool and solution for implementing Java-like interface architecture in
LabVIEW projects.

Contrary to other solutions providing Java-like interface architecture, AZ Interfaceis simple
while fulfilling basic programming demands.

1.1 Versions

Version number consists of four values:
1. version - altered with mgjor changes causing compatibility and/or conceptual issues;
2. subversion — altered with introduction of major changes,
3. fix—minor changes, f. ex. abug fix or minor performance improvement;
4

. build — has meaning only for developer; f. ex. allows accounting of development
packages, specia assemblies, etc.

Altered version or subversion can cause a need in reading updated manual, while altered fix or
build does not affect the way of use.

1.1.1 Version 0.0.0-pre-alpha

First functiona version of the toolkit.
The version was presented at European CLA summit in Madrid, 2018.

1.1.2 Version 1.0.0-alpha

The version basically differs from v.0.0.0.
Thisversion isresult of brainstorming at European CLA Summit 2018:
first, the concept was presented as aregular lecture;

second, pitfalls were extensively discussed/brainstormed with Stephen Loftus-Mercer,
National Instruments.

third, the lecture was repeated and many other experts participated in brainstorming.
| highly appreciate contribution of all participants of these sessions /Andrei Zagorodni



1.1.2.1 Release 1.0.0.0

First public release of AZ Interface software.

1.1.2.2 Release 1.0.0.1

Public release including few small fixes.
Main fix: Improved HD folder selection algorithm for newly created AZ Interface.

1.1.3 Version 1.1.0-alpha

Reentrant execution of AZI methods is implemented. The reentrancy is "limited", see
section 6.6.

1.1.4 Version 2.0.0-beta

Relationships between interfaces and interface-applying classes are altered. Each class
“knows” about applied interfaces while interfaces do not “know” about implementing classes.

Upgrading from version 1 to version 2 is described in section 4.4.

1.1.5 Version 2.1.0-beta/alpha

Consistency tool (see chapter 5) is added to v.2.0.
Note: There are differences between file structures of v.2.0 and v.2.1.



1.2 Conventions

1.2.1 Shortenings and abbreviators

Abbreviator Description

AZI AZ Interface

[ azi Nane] Any name of AZI

BD Block Diagram

FP Front Panel

HD Hard Disk

[ LabVI EW Location of LabVIEW in this computer; for example

C.\Program Fil es (x86)\National |nstruments\LabVl EW 2016\

[ met hodNane] | Any name of a method

OOoOP Object-Oriented Programming

SW Software; AZ Interface software

1.2.2 Font conventions

Bold is used for anything that appears literally in a LabVIEW environment or in
LabVIEW program. For example, for menu, labels that cannot be altered.

Italic is used for terms and messages.
Const ant W dt h isused for values: paths, names, €tc.
[ ] — brackets surround selectable values.

Green Italicis used for private notes.

1.3 Concept of Interface in other languages

Concept of Interface was developed to substitute multiple inheritance in some Object
Oriented languages (OOP languages). Probably the most known of them is Java.

Similarly to LabVIEW, a Java class can have only one parent class; i.e. class hierarchies have
tree-like structures. Java Interface allows creating "cross-links' between trees; i.e. smulate
multi-parent behavior. The concept isillustrated by

Figure 1.
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Figure 1 Interface in UML diagram

Subcl assAand Subcl assB belong to different hierarchical trees. | nt er f aceC provides
common behavior to these classes with no effect on hierarchical positions of classes Super A

and Super B.

Java Interface provides an own data type allowing to work at corresponding abstraction layer.

Java Interface can be considered as an Abstract Class having only abstract methods.
Attributes are not alowed in Interfaces. Otherwise | nt er f aceC behaves exactly in the

same way as any super-class.

SubclassB

+Hethedi




2 AZ Interface Background ldeas

2.1 Solutions

AZ Interface (AZI) utilizes capacity of Call By Reference node.

Each AZ| is assembled as a native LabVIEW class. No class hierarchies are allowed between
AZl-s,

Relation between AZI and Class applying the interface is defined by adding the AZI in list of
Friends (Community scope) of the Class.

2.2 Features

AZl-s alow creating abstraction levels independent on hierarchical structures of classes.

AZl-s dlow abstraction of functionality independently on implemented OOP model; i.e. same
methods of the same AZI can be applied in native LabVIEW classes, GOOPS3 classes, GOOP4
classes, and G# classes.

LabVIEW code created with toolkit can be opened, edited and run without installation of the
toolkit. The codeis not limited to LabVIEW development environment; corresponding EXE-
files can be run under conventional LabVIEW RTE. However, developer must take care about
inclusion of invoked code in build specification (that is the same for any LabVIEW code
invoked with Call By Reference node).

2.3 Limitations

The code is not imperative; for example inconsistency between terminal patterns is not
shown in Error list window.

No hierarchy between AZ Interfaces can be established.

Current version is tested only for My Computer branch of LabVIEW Project. Use of
the toolkit with other targets was not tested yet. This limitation will be resolved in
future.

AZ Interface Consistency tool announced for v.0.0.0 is not included in following
versions. Need in functions of this tool disappeared due to altering of the whole
concept. New tool will be created in future if new needs will be identified.

Connector pane of AZI methods use terminal pattern 6x4x4x6 only. Altering the
terminal pattern would cause errors that are difficult to fix.



Connector pane terminals of each AZI method must be assigned before the method is
applied in one of classes. Later changes could require significant efforts. | am still
thinking how to do such operations easier.



3 System Requirements and Installation

3.1 Requirements

Current version of the toolkit is developed for LabVIEW 2016 and expected to be fully
functiona with following versions of LabVIEW.

No additional package is required.
Ask me if you need the toolkit for an earlier version of LabVIEW. | can downgrade the code.

3.2 Installation

No installer is supplied with current version of the toolkit. Files must be manually copied in
corresponding LabVIEW directories.

Files belonging to older version of AZInterface must be deleted before installation.

3.2.1 File location

Files must be copied in different directories of LabVIEW. The table below refers to
[ LabVI EW directory that, for example to,

C.\Program Fil es (x86)\National I|nstrunents\LabVl EW 2016\

Content of the following source directories must be copied into corresponding target
directories.

Supplied files Target LabVIEW directory

GProvi ders [ LabVI EW \ r esour ce\ Fr amewor k\ Pr ovi der s\ GPr ovi der s\
Provi ders [ LabVI EW \ r esour ce\ Fr amewor k\ Pr ovi der s\

Proj ect [ LabVI EW \ r esour ce\ Fr amewor k\ pr oj ect \

hel p [ LabVI EW \ hel p\

3.2.2 Recompiling

In some cases files of the toolkit must be recompiled after the copying; f. ex. VIs must be re-
saved accounting to new locations of sub-VIls.
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To do it open consequently two VIs. These Vis are used only for manual installation. Ignore
messages concerning atered file locations. Order of opening could be important:

1. Open LabVIEW.

2. Open
[ LabVI EW\ hel p\ AZ Interfaces\_1 all _hel p_AZ Interfaces.vi

3. Open
[ LabVI EW\ r esour ce\ Fr anewor k\ Provi der s\ AZ I nt erfaces\
3 all _providers_AZ Interfaces.vi

4. Open
[ LabVI EW\ proj ect\ AZ I nterfaces\
4 all _project AZ Interfaces.vi

5. Click menu File > Save All.
6. Closedl VI-s.
Restart LabVIEW.

11



4 Primary Functions of the Toolkit

Note: when working with AZI and AZI-applying Class all involved files must not be write-
protected. Remove write-protection from the AZI , the Class, and al their members.

4.1 Creating AZI

1. Right-click the My Computer or any Virtual Folder and select menu AZ I nterfaces
> Create AZ Interface.

2. Createlnterface dialog will be opened.
3. Write name of new AZI class, use other input fields if needed.
4. Click Create Interface.
Pink background indicates invalid input value; f. ex. invalid name, namein use, etc.

LabVIEW class will be created in selected location. Newly created AZI includes three
members:

cast _to_Interface.vi - utility method caled only by automatically created
methods of AZI-applying classes.

nmet hod_refs. ctl —utility type definition that is part of AZI private data.

0 The type definition is also used in automatically created methods of AZI-
applying classes.

read_QObj ect.vi — method is used for back-casting from AZl data type to data
type of particular class.

0 The method should usually be followed with node To More Specific Class.

o The method optionally destroys instance of AZI (but not instance of the class),
See section 6.5.3.

4.2 Creating AZI method

1. Right-click the AZl class in LabVIEW project and select menu AZ Interfaces >
Create Interface method.

2. Write name of the method in the opened dialog and click Create method button.
3. Open Front Panel of the newly created method.

12



4. Create controls and indicators and connect them to terminal pattern of the VI.
Do not select another terminal pattern; only 6x4x4x6 pattern is supported.
Do not disconnect existing terminals.

ATTENTION: atering terminals (number of terminals, they assigning in terminal
pattern, data types) after overriding the method in AZI-applying class(es) will
cause a need in extensive manual work (see section 6.3). Thus be careful at this

step.
Do not edit Block Diagram of the method.

6. Optionaly ater icon of the method, these changes will propagate in icons of
corresponding methods in AZI-applying classes.

7. Savethe method.

8. Savethe whole AZI (Select classin the project then right-click menu Save > Save Al
(this Class) or select menu File> Save All).

Block Diagram (BD) of the newly created method (see Figure 2) contains default code and
terminals of user-created controls/indicators. This BD will be automatically altered when the
method isfirst applied in any AZI-applying class (see section 4.3.2).

Do not edit BD| ging

Murmeric :@ ]
[=ie '
Boolean Path
Interface_object in i = Interface_object out
3 method refs.method.vi G o B method refs.method.vi o
[l Mo vossnoss vovsaossieseis] — “E> 2 O POBT]
- Object Object Gl
MJHHE-

error in (no error) error out

Figure 2 Example of newly created AZI method

4.3 Applying AZI and AZI methods to Class

The same dialog is used for applying AZI to Class and for implementing AZI Method in the
Class.

1. Right-click any class in the project then select menu AZ Interfaces > Apply
Interface.
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2. The diaog appears listing al available AZI-s (Figure 3). List interface methods is
popul ated with methods of AZI selected in list I nterfaces.

L2 Implerent intsrface o G lvclass LJ
File Window Help |ﬁ
2> @n b |:~l-j

interface methods

Dynamic
dispatch

Figure 3 GUI used for applying AZI to Class.

4.3.1 Applying AZI to Class

1. Select anitem from list Interfaces. Thelist shows all AZI-s available in the Project.

If selected AZI is already applied to the Class, button at bottom of the list is
disabled exposing text "Interface is applied” (see Figure 3). In this case select
another AZI, continue working with methods (section 4.3.2), or click Close.

2. Click button Apply interface.

Applying AZI to aClassresultsin:
The Classis added in AZI lists of Friends.
The AZI isadded in Class lists of Friends.
New method is added to the Class:

0 The method is named cast _to_[ azi Nane] . vi, where [ azi Nane] is
name of the AZI.

o Thismethod is used for casting of corresponding Object to type of the AZI. In
some sense the casting is similar to one performed by nodes To M ore Specific
Classand To More Generic Class.

0 The method cast _to_[azi Nane].vi is initialy broken. It will be
repaired automatically (its Block Diagram altered) when any AZI method is
applied in the Class (see section 4.3.2).

14



4.3.2

Implementing AZI methods in Class

Select an item from AZI list I nterfaces (see Figure 3).

List interface methods at right-hand shows methods available in this AZI.

If selected AZI is not yet applied to the Class, button Apply interface at bottom of
thelist is enabled. In this case click button Apply interface, select another AZI, or
click Close.

Select method in the list interface methods. Methods already applied in this Class are
disabled.

Click button Implement method.

Applying AZI method to a Class resultsin:

The method is added in the Class:
0 The method has necessary terminal pattern.

o Block Diagram of the method is initially empty. All coding of the method
(including wiring of class terminals) must be performed manually.

Utility method ut i I _[ azi Nane] _cl s_[ met hodNan®e] . vi iscreated:

o Name of the utility method contains name of the AZI ([ azi Nane] ) and
name of the actual method ([ met hodNane] ).

o The utility method is created automatically and should not be altered.
Block Diagramof cast _t o_[ azi Nane] . vi method isautomatically altered.

0 The method is repaired if it was broken (the method being created is
initially brocken).

Block Diagram of corresponding AZI method is rewired if it was not done earlier.

4.4 Upgrading from v.1 to v.2

Version 2 of the toolkit cannot be used for further development of AZI-s created with
version 1. If aproject contains v.1 AZI, right-click will open menu AZ I nterfaces > Upgrade
Interfacetov2.

Upgrading v.1. to v.2 does the following:

Sets access scope of AZI method cast_to_Interface.vi to be Public.
Empties AZI’s list of friends.
Setsinterna property of the AZI to bev.2.

15



Upgrade of an AZI does not affect code of AZI-applying classes. However, some
members of these classes could be recompiled at next run.

Note: There is no tool to upgrade AZI-s created in version 0. This is because v.0 was not
released to LabVIEW community.

Note: Thereisno need in upgrading fromv.2.0tov.2.1.

16



5 Consistency Tool

Consistency tool provides help with solving discrepancies in AZlnterface-containing
projects.

5.1 Overview

Current version of Consistency tool (v.2.1) doesthefollowing :
searches for AZI of old versions and updates the version,
searches AZI-applying classes for non-overridden (absent) methods,
searches inconsistency in method terminal patterns and helps in problem fixing.

The Consistency tool is avalable via menu Tools > AZ Interfaces >
AZ Interface Consistency tool...

GUI of thetool is shown in Figure 4.
[ £ Az Inleﬁafe"tor;;au‘)ol-'-"

File Window Hzlp
a2 @ 9

Chandreyprojects\AZ Interfaces_noSV..\tmpitest190302-1 - Copy\a.vproj J

Investigate Alter method_refs.ctl Close
Intl A | E Terminals are not wired in BD |
Intl-] DDDwvi E Terminal pattem differs from defined in method_refs.ct |
Intl-1 CCCwi E Terminals are not wired in BD |
Infl-1 SBBw E Terminals are not wired in BD 7 |
!
|
|
i
|
Figure 4 AZ Interface Consistency tool

1 - Path to investigated LabVIEW project.
2 — Button I nvestigate/Stop.

3 — The button calls automatic fixing of selected error (see section 5.3). Text of the button
varies.

4 — Button Close.
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5— 2D progress bar (see section 5.2.2).
6 — Category selector — radio buttons (see section 5.2.3).

8 — Inconsistency report table (see section 5.2.4).

5.2 GUI

5.2.1 Start investigation
Select LabVIEW project in field (1), see Figure 4, then click button I nvestigate (2).

Investigation can be interrupted with button Stop (2).

5.2.2 Progress indicator
2D progress indicator (5), see Figure 4, shows progress through steps of investigation (up-
down) a, through each step (Ieft-right).

Besides it indicates fraction of inconsistent objects. Errors are indicated with red; warnings
are indicated with yellow bars.

5.2.3 Category selector
The selector (6), see Figure 4, allows paging through different categories of identified
inconsistencies. Found errors are described in inconsistency report table (7)

Each radio button of the selector is located against corresponding bar of progress indicator
(5). If no error or warning is found in the category (the bar is green), corresponding radio
button is disabled.

5.2.4 Inconsistency report table

The table (7), see Figure 4, presents errors belonging to one category. Errors are abbreviated
with letter "E"; warnings are abbreviated with letter "W". Categories of errors are selectable
as described in section 5.2.3. The errors are described in following sections.

5.3 Fixing errors

Consequent fixing of errors if recommended. This means: fix errors in interfaces first then
attend errorsin classes.

18



Some automatic fixing algorithms are straightforward. Others are described below.

5.3.1 Solving inconsistency in AZI method terminal pattern

The reported error is Terminal pattern differs from defined in method_refs.ctl.

Manual altering of AZI method terminal pattern inevitably causes inconsistency in al related
method and utilities. Type definition met hod_r ef s. ct | must berectified first.

Consistency tool does the work. However, it can affect other members of the project.
Rescanning the project (see section 5.2.1) is highly recommended after such afix.

5.3.2 Solving inconsistency in class method terminal pattern

The reported error is Terminal pattern does not match pattern of interface method.

Consistency tool altersterminal pattern accordingly to termina pattern of the overridden AZI
method. |.e. controls and indicators of the class methods are added/removed/replaced.

This could cause errors in BD of the method. To avoid confusions *“old” controls and
indicators are not deleted but only disconnected from terminal pattern. “New” FP objects are
connected to terminal pattern but their terminals are not connected in BD.

Thus (ATTENTION!) developer must attend each altered class method and rewire terminals.

19



6 How to Use

6.1 General example

Use of AZI-s can beillustrated by Block Diagram presented in Figure 5. Three classes are not
hierarchically related while all three apply the same AZI.

Objects belonging to three different OOP models are created (GOOP, G#, and Native
LV Class) then processed at common abstraction level of the AZI. Finally, the objects are cast
back to initial classtypes.

1000000000 0000000 0000000000000000000000000000000000000000000000.0 @«L

Create Objects of | | Cast objects Work at Interface abstraction level Cast to types of particular classes | | Processing at
different types to Interface levels of
abstraction N particular

classses

R ity Lo ]

e —— GOOF | . .
. b

MET u g INT .
= LB GOOF
o
= OEJECT leiet £ .
I
G
o i &% i |
bk e
A INT I =
Aol [ )
OEJEGT o w'a] ,ch
i ]
:
pociciibo oo i i
Aol s Ly
DEJECT looe’n] FOST
FROC.

OO00O0000000000000000000000000000000000000000000000000000000000030a0«0:

Figure 5 Example of AZI use.

6.2 Working with class hierarchies

6.2.1 Sub-classes of AZI-implementing class

Any child of an AZI-applying class can override AZI methods. There is no need to apply the
same AZI to each sub-class of the hierarchy.

20



6.2.2 Two AZl-implementing classes belonging to same hierarchy

A need in applying the same AZI to different classes of the same hierarchy is rare (see
section 6.2.1). At least | cannot identify such a need. However; this can be done changing type
of object terminals of all conflicting methods to Dynamic Dispatch.

6.3 Altering terminals of AZI method

6.3.1

Modifying terminals manually

Connector pane terminals of each AZI method must be assigned before the method is applied
in any AZl-applying class. However, a need in altering termina signature could arise.
Terminal signatures of the following VIs must differ only by type of object terminals:

6.3.2

AZI method must have object terminals of AZI type.
Corresponding class methods must have object terminals of corresponding class type.

Utility methodsut i | _[ azi Name] _cl s_[ met hodNane] . vi (see section 4.3.2)
must have object terminals of LabVIEW Object type.

Corresponding element (VI Refnum) of net hod _refs.ctl (see section 4.1)
belonging to the AZI must have object terminals of LabVIEW Object type; i.e. the
glement must have the same signature as  utility = method
util _[azi Nanme] _cl s_[ nmet hodNane] . vi .

Using Consistency Tool to modify terminals

Create/remove/replace desirable control and indicatorsin AZI method.
Save the method.
Start Consistency tool and scan the project (button I nvestigate, (2) in Figure 4).

Select category Interface methods (selector (6) in Figure 4); then the AZI method
exposing error Terminal pattern differs from defined in method_refs.ctl.

Fix the error (button (3) in Figure 4).
Rescan the project (button I nvestigate, (2) in Figure 4).

Select category Class methods (selector (6) in Figure 4); then one of overriding class
methods exposing error Terminal pattern does not match pattern of interface method.

Fix the error (button (3) in Figure 4).
Open the method and rewire terminalsin BD.

Treat method of next class overriding the same AZI method; and so on.

21



For details see sections 5.3.1 and 5.3.2.

6.4 Instances of classes and interfaces

Note: control of class and interface instancing is especially important for use of AZI-s, which
include reentrant methods. Missing to destroy instances of such AZI-s result in unused refs left
in memory. This is true even if reentrant methods are not invoked in particular run of
program.

6.5 Concept of "limited" reentrancy

6.5.1 Instancing of a class

Instancing/creating objects of LVOOP class is illustrated in Figure 6. New object (instance)
Is created with class constant or when class wire is branched.

Ly e
i Instance 1 =
d
Lw —
i Instance 2 Instance 2 j
Instance 3 K

Figure 6 Instancing of a by-value class (LVOOP class)

Contrary to by-value classes, instances of by-ref classes (GOOP or G#) are created only with
class constructor (see Figure 7). Forking of class wires copies only ref, which points to the
same instance of the class.
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GOOF

- Instance 1
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- Instance 2 Instance 2

[
Instance 2 E

[ ]|

e
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Figure 7 Instancing of a by-ref class (GOOP or G# class)

6.5.2 Instancing of an AZI

Each AZI instance carries wrapped object of native or by-ref object and references to methods
of corresponding class. Thus AZI itself is by-ref solution, however behavior of particular AZI
instance differs for different OOP models. Figure 8 illustrates instancing behavior of AZI
wrapping by-value class while Figure 9 illustrating instancing behavior of AZI wrapping by-
ref class.

o
... Instance 1 wrappedin AZI1 &
Instance 1 g = I
B )
Instance 2 wrapped in AZl 2
LW boovororssrsrsssisinisiisisa: i rrrrrariars i s i
Instance 2 L I
Instance 3 wrapped in AZ) 2 [
Figure 8 Instancing of a LVOOP class wrapped in AZI
il S 1 B vsssnnse OLANEE 1 WIAPRED N AZL L s P
nstance
] e D
Instance 1 wrapped in AZ 2
TEpm— Lo T s E
:-.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l.l:l.l.l.l.l.l.l.l.l.l.l.l.lE
Instance 1 wrapped in AZ 2 .
Figure 9 Instancing of a GOOP or G# class wrapped in AZI
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6.5.3 Destroying instances of AZI

AZI is by-ref solution. Thus each instance of AZI should be destroyed when not needed any
more. However, AZI-s having no reentrant methods carry only static references thus their
destruction is meaningless.

AZl method r ead_(Obj ect . vi destroys instance of AZI closing dynamic VI references.
However, only refs to reentrant methods are created dynamically thus only instances of such
AZl-s must be destroyed.

Figure 10 illustrates concept of destruction.

loogooooooooooooonoooonoooonoooonoonnooonnooonoonnoonnn

Cast object to AZT Work at AZT abstraction level Destroy instances of AZT
L[ ] IMT L'[g
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Figure 10 Concept of AZI destroying. Each instance created with method cast _t o_[ azi Nane] . vi
should be destroyed using method r ead_Cbj ect . vi

6.6 "Limited" reentrancy, parallel execution

Independent (parallel) execution of reentrant methods (clones) can be achieved only for
different instances of AZI.

This can beillustrated considering behavior of reentrant method MET. vi asshownin

Figure 10. Three calls of the method are shown while only two can be executed in parallel.
Middle and bottom calls cannot be executed simultaneously because they belong to the same
instance of the AZI.
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6.7 Programming, good programming style

6.7.1 Using read_Object.vi

Method r ead_Qbj ect . vi hastwo purposes:
conversion from AZ| datatype to datatype of particular class,

destroying instance of AZI.

The concept isillustrated in Figure 11

[Cast object of LV.class type. | [Destroyed AZI wire.|

[Wark at AZT abstraction level.| Obtain wrapped object and

destroy instance of AZL

|Obtain wrapped object.|

|Wu:urk at AZT abstraction level |
B iviveirs L_[]L ............... L%H;; ............................................................................ \\ML_[]E ............... L%%Tr .................................................... 1
D!&BQD MER E OEJECT MER OEJECT

/4 Ly Ly
Cast object to type of the AZT.
l.e. wrap ohject in AZL

ot Lv ot Lv
cLAsS cLAsS
SREC | =FEc
~ 4

[Cast object back to type of LV-class.|

[Cast object back to type of LV-class.|

[Work at the class abstraction level.|

[Wark at the class abstraction level.|

Figure 11 Usingr ead_Qbj ect . vi

Please note that second call of r ead_(Cbj ect . vi destroys the AZI. However, the AZI wire
can be drown out of the method (Destroyed AZlI wi re in Figure 11). If the AZI does
not include any reentrant methods, the destroying does not have any effect (and not required).

6.7.2 Race conditions

An instance of AZI is only a wrapper around conventional object. Thus most cases of race
conditions should be resolved considering interactions between objects even if execution is
performed at AZ| abstraction level.
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However, destruction of AZI can cause race condition as shown in Figure 12. Upper flow in
this figure can be completed before execution of other flows. If read_Cbj ect. vi is
executed before middle or/and bottom clone of MET. vi , these clones cannot be run.
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Figure 12 Race condition when destroying instance of AZI

The race condition can be resolved in different ways; f. ex. as shown in Figure 13.
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Figure 13 Resolved race condition

6.7.3 Destroying AZI — good programming style

Method r ead_Obj ect . vi cannot launch any error. Thus the method can be used even
during development of the code; i.e. when some AZI methods are not applied yet.

Destruction is meaningful only for AZl including reentrant methods. Thus only instances of
such AZI-s must be destroyed.

However, using one call of read Qbject.vi destructor per each cal of
cast _to_[azi Nane].vi canbe considered asgood programming style.
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7 About and Contacts

Al Interface Toolkit

LabVIEW:
{ Mational Instruments Corporation

: : Copyright © 2016 National Instruments Corporaticon

-

inter o

f a C e Developed by Andrei Zagorodn

andrei.zagorodni@novatorsclutions.se
Version 21.0.0

License Agreement

»

m

1 Acknowledgement

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING
|THIS SOFTWARE. BY USING THIS FREEWARE VERSION YOU ACKNOWLEDGE
iTHAT ¥OU HAVE READ THIS LIMITED WARRANTY, UNDERSTAND IT, AND
|AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU ALSO AGREE

THAT UNLESS YOU HAVE A DIFFERENT LICENSE AGREEMENT SIGNED BY
ANDRE ZAGORODNI YOUR USE OF THIS SOFTWARE INDICATES YOUR
ACCEPTANCE OF THIS LICENSE AGREEMENT AND WARRANTY. IF YOU DO

NOT AGREE TO THE TERMS OF THIS AGREEMENT, DELETE THE SOFTWARE
FROM ALL STORAGE MEDIA. -

Figure 14 About

7.1 License Agreement

1 Acknowledgement

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING
THIS SOFTWARE. BY USING THIS FREEWARE VERSION YOU ACKNOWLEDGE
THAT YOU HAVE READ THIS LIMITED WARRANTY, UNDERSTAND IT, AND
AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU ALSO AGREE
THAT UNLESS YOU HAVE A DIFFERENT LICENSE AGREEMENT SIGNED BY
ANDRElI ZAGORODNI YOUR USE OF THIS SOFTWARE INDICATES YOUR
ACCEPTANCE OF THIS LICENSE AGREEMENT AND WARRANTY. IF YOU DO NOT
AGREE TO THE TERMS OF THIS AGREEMENT, DELETE THE SOFTWARE FROM
ALL STORAGE MEDIA.
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2 License

This Freeware License Agreement (the "Agreement”) is a lega agreement between you
("Licensee"), the end-user, and developer of AZ Interface Toolkit Andrei Zagorodni
("Developer”) for the use of this software product ("Software"). Commercial as well as non-
commercia useis alowed. By using this Software or storing this program or parts of it on a
computer hard drive (or other media), you agree to be bound by the terms of this Agreement.
Provided that you verify that you are handling the original freeware version you are hereby
licensed to make as many copies of the freeware version of this Software and documentation.
You can dter this Software in any way but Developer does not carry any responsibility for
consequences.

If you alter and/or further develop this Software, documentation (including "help" and
"about™) must include reference to original Software, name of its Developer and his contacts.

3 Limited Warranty and Disclaimer of Warranty

The AZ Interface Toolkit EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE
SOFTWARE. THIS SOFTWARE AND THE ACCOMPANYING FILES ARE PROVIDED
"AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OF
MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR
IMPLIED, OR NONINFRINGEMENT. THIS SOFTWARE IS NOT FAULT TOLERANT
AND SHOULD NOT BE USED IN ANY ENVIRONMENT WHICH REQUIRES THIS. NO
LIABILITY FOR DAMAGES. In no event shall AZ Interface Toolkit or its suppliers be
liable for any consequential, incidental or indirect damages whatsoever (including, without
limitation, damages for loss of business profits, business interruption, loss of business
information, or any other pecuniary loss) resulting of the use of or inability to use this
SOFTWARE EVEN IF the Software HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES. The entire risk resulting of use or performance of the SOFTWARE
remains with you.

4 Copyright

Copyright (c) by Andrei Zagorodni.

7.2 Contacts
Andrel Zagorodni

andr ei . zagor odni @ovat or sol uti ons. se
Please write AZI or AZ Interfacesin subject line.
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7.3 Support and communications

| shall appreciate feedback about bugs and bottlenecks identified in this SW.

| promise to read your emails and reply within reasonable time. However the project is
developed in my evenings and weekends. Thus the "reasonable time" will solely depend on my
work load.

You are free to modify code of the software. However | do not promise to support the modified
code.

Andrei Zagorodni
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